Troubleshooting EtherNet/IP I/O

Using the Event Log

The Event Log is the primary troubleshooting tool in the RMC for EtherNet/IP I/O. It can record every change in the EtherNet/IP I/O data received (consumed) by the RMC. This is the Output Data from the PLC. It does not record the data produced by the RMC (the Input Data in the PLC).

The Event Log can report the following events based on Incoming I/O Data:

Using the Communications Statistics

To open the Communication Statistics window, in the Project pane, select the desired controller. On the Controller menu, choose View Communication Statistics.

The Communications Statistics window provides information on open EtherNet/IP I/O connections, such as the producing and consuming registers and the RPI, along with information on timed-out connections. The statistics also provide advanced information on the Ethernet traffic.

Incompatibilities with Older Allen-Bradley Ethernet Modules

The following problems have been seen when using the RMC controllers with Allen-Bradley Ethernet modules:

Problem #1:

I/O connections drop repeatedly resulting in error 0x0203 being reported in the Allen-Bradley Ethernet module

 

Cause

A number of Rockwell Automation Ethernet modules with older firmware are incompatible with the Quality-of-Service object in EtherNet/IP. The Quality-of-Service (QoS) object allows managed Ethernet switchgear to prioritize EtherNet/IP packets to provide higher levels of determinism. The QoS object was defined by ODVA (https://www.odva.org) to be backward compatible with devices that did not support the QoS object.

Some devices incorrectly handle the default QoS object behavior of marking I/O data with non-zero DSCP values, including some Rockwell Automation Ethernet modules with older firmware, causing the EtherNet/IP I/O connection to time out with error code 16#0203 shortly after it is established.

This does not apply to RMC75/150 firmware 3.40.1 or older, as that firmware did not support the QoS object.

Rockwell Automation is aware of the problem, and has a knowledge base article that discusses the issue (#63904 - https://rockwellautomation.custhelp.com/app/answers/detail/a_id/63904/) and suggests that users update the firmware in their Ethernet modules to fix the issue. The following firmware revisions fix the problem in the following Rockwell modules:

Rockwell Module

Firmware Revision

1788-ENB

2.004.1

L2xE/L3xE

V17

1756-ENBT

4.005.1

1756-EWEB

4.005.3

1768-ENBT

2.001.0

1768-EWEB

1.002.9

1794-AENT

4.001.1

If you have one of these modules with an older revision, then you should update the Rockwell Ethernet module firmware, if possible.

 

Solutions

There are two possible solutions:

    1. Update Rockwell Module firmware (recommended)
      Update the firmware in the affected Rockwell Ethernet module.

    2. Disable Non-Zero DSCP Values in RMCTools
      This is not necessary if you followed the recommended solution #1.
      In RMCTools, do the following:

      1. In the Project tree, expand the Modules folder and double-click the RMC CPU.

      2. On the EtherNet/IP page, in the Quality of Service (QoS) section, uncheck the Enable DiffServ Code Point (DSCP) marking box.

      3. Click OK to apply the changes to the RMC. Ensure that the settings are saved to flash and the module is restarted.

Problem #2:

I/O connections are lost approximately 2 minutes after they are established, are successfully re-established, but continue to be lost every two minutes.

Cause

RMC75/150 firmware 3.63.0 (February 2016) and newer, and RMC200 firmware, include an “Encapsulation Inactivity Timeout” parameter. This is an EtherNet/IP requirement, and must default to closing an inactive TCP/IP connection used by EtherNet/IP after 2 minutes.

Older Allen-Bradley 1756-ENBT (prior to 4.007) and 1756-EN2T (prior to 1.004) Ethernet bridge modules will incorrectly close any EtherNet/IP I/O connection that was opened using the TCP/IP connection. This is seen in the RMC event log by the CIP IO connection timing out or being closed nearly exactly when the EtherNet/IP inactivity timeout occurs, which is also reported in the Event Log.

Solutions

There are two possible solutions:

    1. Update Rockwell Module firmware (recommended)
      Update the firmware in the affected Rockwell Ethernet module.

    2. Disable Encapsulation Inactivity Timeout
      This is not necessary if you followed the recommended solution #1.
      In RMCTools, do the following:

      1. In the Project tree, expand the Modules folder and double-click the RMC CPU.

      2. On the EtherNet/IP page, in the Encapsulation Inactivity Timeout section, set the Timeout to 0. This disables the timeout.

      3. Click OK to apply the changes to the RMC. Ensure that the settings are saved to flash and the module is restarted.

 

See Also

EtherNet/IP Overview


Send comments on this topic.

Copyright © 2025 Delta Computer Systems, Inc. dba Delta Motion